$re = '/(?:\btype|(?!^)\G,)\h*\K[^,\s]*/m';
$str = 'type MyType1
type MyType2, MyType3
type MyType4, MyType5, MyType6
NotMyType1, NotMyType2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);