using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<Protocol>https?):\/\/)?(?:(?<Subdomain>[\w\.]+)?\.)?(?<Hostname>\w+)\.(?<Domain>\w+)\:?(?<Port>\d+)?(?<Path>\/.*)?";
string substitution = @"";
string input = @"https://regex101.com/";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}