const regex = /(?:(?<Protocol>https?):\/\/)?(?:(?<Subdomain>[\w\.]+)?\.)?(?<Hostname>\w+)\.(?<Domain>\w+)\:?(?<Port>\d+)?(?<Path>\/.*)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<Protocol>https?):\\\/\\\/)?(?:(?<Subdomain>[\\w\\.]+)?\\.)?(?<Hostname>\\w+)\\.(?<Domain>\\w+)\\:?(?<Port>\\d+)?(?<Path>\\\/.*)?', 'g')
const str = `https://regex101.com/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);