re = /(?:(?<Protocol>https?):\/\/)?(?:(?<Subdomain>[\w\.]+)?\.)?(?<Hostname>\w+)\.(?<Domain>\w+)\:?(?<Port>\d+)?(?<Path>\/.*)?/
str = 'https://regex101.com/'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result