using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<td.*style="".*)(;)("".*>)(?:In order to stop receiving)";
string substitution = @"$1$2$3";
string input = @"<tr>
<td style=""color:#555555;padding-top: 3px;padding-bottom: 20px;"">In order to stop receiving similar emails, simply remove the relevant <a href=""https://domain.tld/dashboard/?module=saved-searches"" target=""_blank"">saved search</a> from your account.</td>
</tr>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}