using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+:(?|(\w+)|""(\w+)(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?"")";
string input = @"name:mark
name:""mark""
name:""mark wilson""
name:""mark wilson wilson wilson wilson wilson wilson""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}