re = /\w+:(?|(\w+)|"(\w+)(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?")/m
str = 'name:mark
name:"mark"
name:"mark wilson"
name:"mark wilson wilson wilson wilson wilson wilson"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end