$re = '/\w+:(?|(\w+)|"(\w+)(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?(?:\h+(\w+))?")/m';
$str = 'name:mark
name:"mark"
name:"mark wilson"
name:"mark wilson wilson wilson wilson wilson wilson"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);