package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<div[^>]*>([\s\S]*?)<\/div>`)
var str = `<div class="1" >div1</div>
<div class="1" >div2</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}