$re = '/<div[^>]*>([\s\S]*?)<\/div>/m';
$str = '<div class="1" >div1</div>
<div class="1" >div2</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);