re = /<div[^>]*>([\s\S]*?)<\/div>/m
str = '<div class="1" >div1</div>
<div class="1" >div2</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end