#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div[^>]*>([\s\S]*)<\/div>"
Local $sString = "<div class="1">" & @CRLF & _
"abc" & @CRLF & _
"<div>div interna</div>" & @CRLF & _
"xyz" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div>outra</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")