import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div[^>]*>([\\s\\S]*)<\\/div>";
final String string = "<div class=\"1\">\n"
+ "abc\n"
+ "<div>div interna</div>\n"
+ "xyz\n"
+ "</div>\n\n"
+ "<div>outra</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}