using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1[012]?|[2-9]";
string input = @"1 10 11 12
2 3 4 5 6 7 8 9 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}