$re = '/1[012]?|[2-9]/';
$str = '1 10 11 12
2 3 4 5 6 7 8 9 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);