package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`1[012]?|[2-9]`)
var str = `1 10 11 12
2 3 4 5 6 7 8 9 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}