const regex = /^(?=\d{16}$)(6011|65|64[4-9]|622)(\d{1,14})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\d{16}$)(6011|65|64[4-9]|622)(\\d{1,14})$', '')
const str = `6221261418731541`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}