$re = '/^(?=\d{16}$)(6011|65|64[4-9]|622)(\d{1,14})$/';
$str = '6221261418731541';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);