import Foundation
let pattern = #"^(?=\d{16}$)(6011|65|64[4-9]|622)(\d{1,14})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"6221261418731541"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}