#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^Subject: )(?:(?!^Attachements:)[\s\S])+"
Local $sString = "From: me" & @CRLF & _
"To: you" & @CRLF & _
"Subject: welcome, this is a long line of subject with two " & @CRLF & _
" lines of text" & @CRLF & _
"Attachements: welcome.jpg, foo.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")