re = /(?<=^Subject: )(?:(?!^Attachements:)[\s\S])+/m
str = 'From: me
To: you
Subject: welcome, this is a long line of subject with two
lines of text
Attachements: welcome.jpg, foo.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end