#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#([0-9A-Fa-f])\1([0-9A-Fa-f])\2{3}"
Local $sString = "#333333" & @CRLF & _
"#666666" & @CRLF & _
"#ff6666" & @CRLF & _
"" & @CRLF & _
"#d7d7d7" & @CRLF & _
"#e5e5e5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")