import re
regex = re.compile(r"#([0-9A-Fa-f])\1([0-9A-Fa-f])\2{3}", flags=re.MULTILINE)
test_str = ("#333333\n"
"#666666\n"
"#ff6666\n\n"
"#d7d7d7\n"
"#e5e5e5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")