$re = '/#([0-9A-Fa-f])\1([0-9A-Fa-f])\2{3}/m';
$str = '#333333
#666666
#ff6666
#d7d7d7
#e5e5e5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);