using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\s,.])";
string input = @"erehT era a tsav rebmun fo secruoser rof gninrael erom tpircsavaJ
oT eb ro ton ot eb, taht si a noitseuq.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}