package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\s,.])`)
var str = `erehT era a tsav rebmun fo secruoser rof gninrael erom tpircsavaJ
oT eb ro ton ot eb, taht si a noitseuq.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}