$re = '/([\s,.])/';
$str = 'erehT era a tsav rebmun fo secruoser rof gninrael erom tpircsavaJ
oT eb ro ton ot eb, taht si a noitseuq.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);