#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\*\*\s\n*.*(?!methodOf)\n*.*\n\s\*\/"
Local $sString = "/** " & @CRLF & _
" * @ngdoc method" & @CRLF & _
" * @name app.admin:AuditLogController#auditsWatch" & @CRLF & _
" * @methodOf app.admin:AuditLogController" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * @ngdoc method" & @CRLF & _
" * @name app.admin:AuditLogController#auditsWatch" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * @name app.admin:AuditLogController#auditsWatch" & @CRLF & _
" */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")