import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*\\*\\s\\n*.*(?!methodOf)\\n*.*\\n\\s\\*\\/";
final String string = "/** \n"
+ " * @ngdoc method\n"
+ " * @name app.admin:AuditLogController#auditsWatch\n"
+ " * @methodOf app.admin:AuditLogController\n"
+ " */\n\n\n"
+ "/**\n"
+ " * @ngdoc method\n"
+ " * @name app.admin:AuditLogController#auditsWatch\n"
+ " */\n\n\n"
+ "/**\n"
+ " * @name app.admin:AuditLogController#auditsWatch\n"
+ " */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}