using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*\*\s\n*.*(?!methodOf)\n*.*\n\s\*\/";
string input = @"/**
* @ngdoc method
* @name app.admin:AuditLogController#auditsWatch
* @methodOf app.admin:AuditLogController
*/
/**
* @ngdoc method
* @name app.admin:AuditLogController#auditsWatch
*/
/**
* @name app.admin:AuditLogController#auditsWatch
*/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}