#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!^|[.!?]\ )\b[A-Z][a-z]+(?:\ [A-Z][a-z]+)*\b"
Local $sString = "This is a Sample Sentence to check the Real Value of this code. Whether it works or Not depends upon the Final Result." & @CRLF & _
"" & @CRLF & _
"UK Parliament" & @CRLF & _
"Hi, Bob" & @CRLF & _
"" & @CRLF & _
"Is this a Question? Yes, and it's a Good one."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")