import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^|[.!?]\\ )\\b[A-Z][a-z]+(?:\\ [A-Z][a-z]+)*\\b";
final String string = "This is a Sample Sentence to check the Real Value of this code. Whether it works or Not depends upon the Final Result.\n\n"
+ "UK Parliament\n"
+ "Hi, Bob\n\n"
+ "Is this a Question? Yes, and it's a Good one.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}