const regex = /(?<!^|[.!?]\ )\b[A-Z][a-z]+(?:\ [A-Z][a-z]+)*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^|[.!?]\\ )\\b[A-Z][a-z]+(?:\\ [A-Z][a-z]+)*\\b', 'gm')
const str = `This is a Sample Sentence to check the Real Value of this code. Whether it works or Not depends upon the Final Result.
UK Parliament
Hi, Bob
Is this a Question? Yes, and it's a Good one.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}