package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-zA-Z0-9,:\S/-]*)$`)
var str = `mayank
mayank shankar
mayank She,nkar
mayank S'hankar
Mayank S\`hankar
mayank S‘hankar
mayank S’hankar
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}