re = /^([a-zA-Z0-9,:\S\/-]*)$/mi
str = 'mayank
mayank shankar
mayank She,nkar
mayank S\'hankar
Mayank S`hankar
mayank S‘hankar
mayank S’hankar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end