import re
regex = re.compile(r"^([a-zA-Z0-9,:\S/-]*)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("mayank\n"
"mayank shankar\n"
"mayank She,nkar\n"
"mayank S'hankar\n"
"Mayank S`hankar\n"
"mayank S‘hankar\n"
"mayank S’hankar\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")