use strict;
my $str = '/IP/backup_jun20_2017/proddb/application_profile/mth_end_dt=2016-10-31/000000_0';
my $regex = qr/(.*)\/([^\/]+)/p;
my $subst = '$1\\n$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";