// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)\/([^\/]+)").unwrap();
let string = "/IP/backup_jun20_2017/proddb/application_profile/mth_end_dt=2016-10-31/000000_0";
let substitution = "$1\\n$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}