$re = '/(.*)\/([^\/]+)/';
$str = '/IP/backup_jun20_2017/proddb/application_profile/mth_end_dt=2016-10-31/000000_0';
$subst = "$1\n$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;