using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(400022|642398|400023)\d{10}$";
string input = @"4000227890123456
6423987890123456
4000237890123456
4000247890123456
400023890123456
40002378901234564";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}