import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(400022|642398|400023)\\d{10}$";
final String string = "4000227890123456\n"
+ "6423987890123456\n"
+ "4000237890123456\n"
+ "4000247890123456\n"
+ "400023890123456\n"
+ "40002378901234564";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}