import re
regex = re.compile(r"^(400022|642398|400023)\d{10}$", flags=re.MULTILINE)
test_str = ("4000227890123456\n"
"6423987890123456\n"
"4000237890123456\n"
"4000247890123456\n"
"400023890123456\n"
"40002378901234564")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")