package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^]]*](*SKIP)(*FAIL)|-`)
var str = `abc-def]
Radio Stations-Listened to Past Week-Toronto [FM-CFXJ-93.5 (93.5 The Move)]
Total Internet-Time Spent Online-Past 7 Days`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}