re = /\[[^]]*](*SKIP)(*FAIL)|-/
str = 'abc-def]
Radio Stations-Listened to Past Week-Toronto [FM-CFXJ-93.5 (93.5 The Move)]
Total Internet-Time Spent Online-Past 7 Days'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end