import Foundation
let pattern = #"\[[^]]*](*SKIP)(*FAIL)|-"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
abc-def]
Radio Stations-Listened to Past Week-Toronto [FM-CFXJ-93.5 (93.5 The Move)]
Total Internet-Time Spent Online-Past 7 Days
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)