using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[(?:[^][]++|(?1))*])(*SKIP)(*FAIL)|-";
string input = @"abc-def]
Radio Stations-Listened to Past Week-Toronto [[F[]]M-CFXJ-93.5 (93.5 The Move)]
Total Internet-Time Spent Online-Past 7 Days";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}