// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[(?:[^][]++|(?1))*])(*SKIP)(*FAIL)|-").unwrap();
let string = "abc-def]
Radio Stations-Listened to Past Week-Toronto [[F[]]M-CFXJ-93.5 (93.5 The Move)]
Total Internet-Time Spent Online-Past 7 Days";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}