package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\\\/:*?"<>|\r\n]+$`)
var str = `C:\Program Files (x86)\Dropbox\Update\1.3.547.1\DropboxUpdateHelper.msi
C:\test\path\file.name
C:\really\long\file.extension1234567890
C:\temp\test.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}