import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\\\\\/:*?\"<>|\\r\\n]+$";
final String string = "C:\\Program Files (x86)\\Dropbox\\Update\\1.3.547.1\\DropboxUpdateHelper.msi\n"
+ "C:\\test\\path\\file.name\n"
+ "C:\\really\\long\\file.extension1234567890\n"
+ "C:\\temp\\test.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}