$re = '/FindMe/';
$str = 'http://example.com/FindMe/john
http://example.com/FindMe/Jill
http://example.com/FindMe/boo/who?=d
http://example.com/FindMe/adamdasfaam
http://example.com/FindMe/ddafdf/adfkhjhad/adsfjd/jddhadk
http://example.com/blahblah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);